Monday, 17 August 2015

ElectroBeat suffers more battery damage!

The ElectroBeat has been sitting unused since the Mia came along a couple of months ago, A week or so ago I decided to take a look at getting it back on the road, I had noticed when I stopped using it last that there was an early sign of battery weakness indicated by the balance drifting outside of normal parameters, I checked the battery condition again in the usual manner by checking the 12 balance cables with my Hobbyking widget and to my dismay I was missing a whole bank of readings in the front battery box! Shit, I pulled the box disassembled and confirmed my worst fear.
One of the cells in a string of nine had lost its ability to hold a charge and the two month sit had caused it to drag a whole string down to dead!
Dammit that is nine more 5S1P Cell packs that I am going to have to attempt to de-solder! Luckily I have just enough spare cells to swap them out.
Swapped out the nine dead cells and balance charged the whole pack, There may be signs of other cells in this box nearing failure but I want to get the pack back together and in the car so I can test a new rotory wafer switch I bought recently that should allow me to wire all 12 balance cables to the Hobbyking battery monitor widget in the car whilst driving and check the status of each bank whilst the car is under load i.e. driving.
All I will need to do is switch between each bank in turn whilst the car is under load and I should be able to spot the voltage drop on any bad cells being much bigger than the others, basically just look for the bank that has the lowest voltage whilst under load, pull that bank and test each cell. It just gives me a way to check the cells under load.  

Tuesday, 23 June 2015

Localized Melting spotted in Mia’s Window Corner!

Calling all Mia owners, Has anyone (any Mia Owner) experienced any damage to the plastic nearest the top left of the passenger window on the Charge plug side of the car?

I have had my Mia for 3 weeks now (Very happy Second Owner) and last night I noticed for the first time that the white plastic roof panel is damaged (Melted!) right in the very top left most corner. (The white plastic is clearly melted with bubbles formed in the plastic itself and very slight browning and hairline black cracks)

It appears that this has possibly been caused by sunlight heating the black window surround and the window somehow focusing it onto the white roof panel right in the corner, as far as I can tell this appears to be caused by environmental heating from sunlight!

Does anyone know if there is any wiring that goes around the inside of the top left corner of the side window nearest the charge plug, I am worried that something internally might be heating this area during charging and causing this damage.

Update: I have since checked the temperature of this corner of the window whilst charging and there is definitely no heating during charging which leads me to believe that this must have been caused by environmental factors i.e. Strong Sunlight being somehow focused by the round window corners and the black window surround, if this is true then it demonstrates a definite design fault.

Tuesday, 16 June 2015

Now Mia is here the ElectroBeat goes off the road for urgent repairs/upgrades at last!

I have been seriously winging it with the ElectroBeat for well over 18 months now, the car was never properly finished in the first place and it is well past due a number of urgent upgrades, in fact the recent issue with the odometer/mph gauge intermittently cutting out (speed would drop to zero and then jump back up) finally convinced me to start looking for an alternative EV to tide me over hence the recent and very lucky Mia find.

Here is a list of the things that need addressing on the Electrobeat

1) Fix the speedometer, I think this is a simple cable break somewhere in the loom, so trace and replace wires.

2) Pull the front battery box and test a couple of banks, I think I may have a couple of failing cells in there somewhere as the voltage drop seems to have increased dramatically recently when under extreme load (i.e. heavy foot)

3) Build a rotary wafer switch 6 pole 12 way to allow me to check the individual banks cell voltage whilst driving, this will be very useful in spotting failing cells as they often only show a problem when under extreme loads, the output of said switch will be the £20 HobbyKing battery test meter that shows voltages for up to 6P cell blocks, the Beat is using a 5P configuration, this would also allow for simplified battery balancing as I could also connect my balancing BC168 through this switch and then balance each set of 9 cells in a bank without the need to disconnect/reconnect and move the BC168 around the car to reach each set of cells, I hope to break out all the balancing wires for all 12 banks of 9 parallel cell packs around the dash somewhere so I can either run the battery monitor or battery balancer from the same 12 way 5 pole switch (need 5 poles as the cellpacks I used in the beat are 5S1P)

4) Remove the charger and insulate it properly from the car chassis not sure exactly how I will do this as there is literally no room for rubber washers AFAIK, this will become evident when I strip the charger from the car.

5) Replace the failing LCD Display in the charger (replacement screen already procured)

6) Update/mod the firmware in the charger so that it allows cv cut off of over 3.99, I need 4.20 for LIPO packs, Thread “10kW / 60A DIY charger open source design” post #2823 on the DiyElectricCar forum posted by arber333 “show the way” using this code 

“Well let me show you the way... I figured out the firmware setting to go over the 3.99V in setup. It goes like this:

// wrap at 3 (for 100s) or at 9 (for 10s and 1s) 
if(x == 0 && digit[x] > 4) digit[x] = 0; // from original 3 , i change to 4 - so you can select 415 for Lipo cell
if(digit[x] > 9) digit[x] = 0;”

7) Mod the charger to provide J1772 EVSE charging capability (not urgent but would be nice)

8) Fix temp sensor on Charger (I broke this during a minor overheat of the charger (monitored, hence the “minor”) after all 4 crappy fans I was using finally failed.

9) Replace the single large fan I am currently using with 2 smaller but as powerful fans, I need 2 fans for fail safe just in case fan fails during unattended charging.

10) Install/connect the rev counter possibly wire to rev meter on dash (would be nice) I will definitely connect it to the controller so that the data feed from the Ethernet port includes RPM information.

11) Install the MPH sensor for the Charge analyst

12) Install the push button controls for the charge analyst 

13) Fix the burned ring terminal I bodged during my last battery box fitting when I dam nearly blew my hand off! (I forgot to insulate the positive and negative terminals (WTF!) whilst lifting one of the three battery boxes into the car and BANG! Three grams of copper instantaneously vaporised and spread around the inside of the motor bay giving it a nice purple haze!

14) Install a LVC loop test button to the dash so I can test the functionality of the Low Voltage cut out Circuit

15) Install a HVC loop test button to the dash so I can test the functionality of the High Voltage cut out Circuit

16) Get some new front tyres fitted.

17) Replace the Lead Acid battery with a Lithium Pack to reduce weight (optional but would be nice) with an LVC this time (already bricked a 12V LIFEPO block due to leaving my lights on one day! DUMMY!

18) Investigate replacement suspension struts (I think the extra weight of the battery boxes is putting greater strain on the tiny suspension struts as I find that it bottoms out when I hit speed bumps to fast) SLOW DOWN YOU MORON!

19) Replace the radio with a decent one that works (the radio is Japanese and wont pickup hardly anything) and strip out the CD changer (and flog it on eBay) as it is very inefficient compared to MP3.

20) Install some sound proofing in engine bay (I notice that even with the hood down the extra covering over the engine bay is enough to completely silence any gear whirr or motor noise) It won’t need much, a couple of inches of sound proofing foam should do.

21) Install a PC that runs from the 12V or Traction Pack so that I can log data (optional)

22) Install a Wireless router connected to PC above for possible battery monitoring BMS etc (Optional)

Wednesday, 10 June 2015

OMG I Just bought another EV!

Ok now this is just getting silly, last week I was surfing eBay looking at the latest EV offerings and potential donor cars as I often do and I stumbled across a poorly listed Electric Car called a Mia, It is a French designed and built 3 seat minibus with a central driving position and two rear passenger seats.
Now this particular Mia was just two years old near mint condition with ~8000 miles on the clock and resided in Watford, The weird thing was that it was listed for 4K yes £4000 GBP, Now maybe it is just me but that seemed almost too cheap so after a little research I discovered that the French company that build these has gone into receivership late last year 2014 and that issue was far from resolved, However the funky looking Mia still looked like a bargain to me and so I watched the listing for a few days and it looked like no one was going to bid on it, So last Saturday I took the plunge and put in a single bid for the 4K asking price not expecting to win it in the slightest, I have bought many things (including cars) from eBay over the years and thoroughly expected the price to rocket in the last minute, It didn’t and I am now the proud owner of said Mia, And I LOVE IT :-)
So let’s get this in perspective, I just bought an EV with a 12KW LIFEPO traction pack AC motor & Controller, Regen, Eco Mode, ABS, Airbags, BMS, central locking, charger (albeit a very slow Type 1 charger) charge cable (again a cheap Chinese crap one) and the entire car is less than 3 years old, I cannot believe my luck! Oh and let’s not forget that this is a proper NCAP tested car not a quad bike with a car like cover as in the G-Wiz.
Now most people (Petrol Heads) will take one look at the Mia and laugh all the way to the gas station as in most people eyes it is completely impractical, but hang on a minute the car was in Watford and I live in Newhaven just east of Brighton, when I called the car dealer after the auction ended he said “are you bringing a trailer” “No” I replied, “I will be driving it home and charging at public charge points along the way” and after much fiddling around signing up to the Polar network and discovering that the availability of type 1 charge points in the south east of England was seriously limited I considered my options, around an hour later after I had done a few AA route planner calcs I realised that In order to get the car the following day (Sunday 7th June) I would need to dump my kids on their grandparents, Luckily my parents live around Copthorne and after another quick route plan I realised that if the 70 mile range of the Mia (Yes 70 Miles!) is to be trusted I should be able to drive it direct from the dealer to my parents in one hit ~65miles, Now this was a little risky but after a bit more research I found that the Mia also sports Regen and Eco Mode so I thought that it was worth the risk and took a tow rope just to be sure I could get it home in the event of unforeseen problems.
After arriving in Watford and getting my first look at the beauty I was taken aback by its near mint condition, apart from the missing radio front plate and a broken window catch (looks like someone may have tried and succeeded in forcing entry to the vehicle) it was perfect, I also found a single minor scratch in the front plastic cover part but this could easily be polished out.
We set off for Copthorne taking the longer but safer route round the M25, I have never driven any car with my foot so lightly on the pedal, I am talking range winning hypermiling to the extreme and with the eco mode permanently set I was amazed at how the Mia was able to recover whole miles just by coasting down hills on the motorway, the car does slow to the point to where you need to put your foot down but the LCD gauge on the dash shows you whether the car is in Eco, doing regen or using current in a very pleasing way with a swinging bar graph with 4 grades on each side, So I spent my entire journey watching this gauge like a hawk and keeping it on two bars when accelerating and trying my best to recover as much as possible when coasting or when you see an obstruction ahead don’t use the brakes but instead just coast to a halt charging the batts in the process.
The Mia rewarded my efforts by getting me to my parents’ house (65 miles) with 6 miles left on the battery meter and as I approached my parents’ house the battery warning light came on just around 50 yards from their door, well done Mia!
Thankfully my parents have a 3 pin socket in their front garden that my dad had fitted many years ago with the intention of putting electric gates in his driveway (Never happened) so I was able to just plug straight in and spend a nice afternoon chatting to the folks whilst my car charged, My dad made few jokes about “Noddy” cars but my mum loved it and I could tell that she wanted one.
So after doing a part (half) charge and checking the distance on AA route planner I set off for home, now here is where I made my fatal mistake, not doing a full charge means that the battery pack does not get time to balance properly (In fact I have just this morning learnt that in order for the pack to balance properly you need to leave it plugged in even when it reaches 100% full until the green charge light stops flashing and goes solid) and so as I approached Brighton I could see that even with my frugal use of the pedal I was not going to make it all the way home after a minor panic I decided that I would go to my work place and charge it there for a few more minutes just to get me home, 20 minutes later and I set off for home, arrived safely with 4 miles left on the clock. Well done Mia my fondness for this little EV grows daily.

Here is the picture from the eBay listing, I will post others very soon.

VC5 & Keys arrive for one of the Mopeds

After waiting for a while for the guy who gave me the 3 Electric Mopeds to send me the keys and paperwork, I received a Jiffy bag the other day with all the keys and just one VC5 and a number plate for the same one.
As it turns out it is for the smallest and oldest AFAIK, a little silver moped called a V-Rider E2GO, someone had attempted to wire it up with 4 Lead Acid batteries, however they had connected them all to the 12V input and so they may well have blown something, Being fooled by the mistaken wire up I tested the moped with the batteries wired wrongly and on connection got a wicked spark, however all the 12V electrics appeared to work as expected just no traction, So I did a little web research and dug around in the box of extra bits to see if I was missing anything, after a while I discovered that this is the moped that has a lithium pack under the riders feet and a 12V Lead acid battery under the seat (leaving space under the seat for the helmet to be locked away)
So I pulled apart the obviously fugged LIPO pack (cells seriously swollen and obviously dead) and put any cells that looked like they might still be ok on a test charge but after attempting to charge 2 of the 4 blocks I found that they won’t hold a charge suggesting that a complete new LIPO pack is needed, Oh well I will probably just try and source replacement cells cheap and rebuild the genuine pack myself from scratch, it appears to have BMS boards monitoring or possibly balancing the cells, so I took a lot of photos when I was pulling the cells out so I can put it back as it was. Watch this space, I intend to get this one on the road at least as a backup for when my car is off the road for repairs/upgrades.

Monday, 18 May 2015

Gifted three electric mopeds

My partner (who is a freecycle-a-holic) said to me the other day “Would you be interested in 3 electric mopeds” obviously my response was a distinctly positive “YES!” and after a little toing and frowing (mainly due to me only having an estate to shift them in) I am now the proud owner of said 3 electric mopeds. 

However I have yet to receive the keys or VC5's the guy that gave them to me is a good frioend of Steve from Jozztek and I understand that this is where they came from originally (Confirmed after speaking with Steve) One is an "Electricycle Retro" I have not had the time to investigate the other 2 due to lack of time, watch this space.

Back on the road

Got my Honda “ElectroBeat” back Wednesday 15th April 2015 picked it up from SMD’d garage after work, I have been driving it to and from work (with a few extra journeys here and their) without a hitch so it looks like the gearbox replacement was a complete success (nice one Brent) and I was amazed that it cost me less than £300 to fit, considering the fact that they had to remove the motor and old knackered gearbox and replace the whole lot along with modifying the (newly acquired second hand) clutch plate and modifying the old coupling plate (basically removing the old modified/cut down clutch plate center and welding in the newly acquired and cut down center part to the old coupling plate) and refitting the whole shebang back into the car, I would call this damn good value.

TBH If anyone who is reading this needs a good mechanic in the Brighton area of Sussex England I would not hesitate to recommend SMD as simply the best mechanics I have ever encountered, Bravo SMD

Still so much to do on the RX8!

To be honest the Rx8 build has not even started properly yet, The Donor car has been stripped out and is ready for the motor fitting, However the coupling of motor to diff has proved more of an issue that I had thought and we will still need to get something made by a machinist, I was going to try and sort this out myself to keep costs down but unfortunately due to other projects (Houses and other boring stuff) I am having to leave this to the mechanics, I hope that they will be able to sort something out soon and get the motor fitted ASAP.

Here is a basic list of what I need to do.

1) Get Motor coupling made and Motor fitted
2) Get Battery boxes made, Get lid fixings fitted, Give to Brent for fitting into RX8 (Angle iron welding required to hold boxes)
3) Give Soliton to Brent for sizing and fitting. 
4) Buy copper buss bar plate and drill on KX3 mill (4 holes per cell x 5 cells per plate = 20 holes per plate)
5) Get the Power steering Canbus widget (needed to enable power steering on RX8) 
6) Line battery boxes with plastic packer and fill with cells.
7) Clean every single battery connection back to dry bright copper, and fit bussbars
8) Source and fit BMS or LVC/HVC boards! (can’t get the Methods boards any more so it might have to be a homebrew BMS)
9) Finish building EMW (V12 control board) charger (need to purchase LCD screen’s ASAP)
10) Source components for reverse, Kilovac relays? (ask Steve)

Easter Holiday Battery testing Completed

I took a few extra days annual leave to pad my Easter break into a good couple of weeks to give me time to finish a few ongoing projects.
One of which was finishing the EIG cell tests for the RX8, So I now have all 351 cells tested and ready for the traction pack construction to begin in earnest.
I stacked a block of 30 cells with the silicone sheets as separators to see how the overall size was affected by my changing the cassette construction, looks good. I now just need to figure out how I am going to mount the cells in the boxes (yet to be made)
I am currently thinking that if I get the boxes (3 of them) made so that I can tightly pack the cells in with a 3mm plastic insulating insert between the Ali box and the cells around the outsides and at the bottom of the boxes this should allow me to secure the cells from moving by packing the cassette tops with some sort of plastic packer bars that will prevent the cells moving inside the boxes, with the addition of the tight fitting and silicone sealed lid that should stop and sort of potential for movement, Steve (Jozztek) suggested using an inflatable bag made from a reclaimed inner-tube at the ends to allow a reasonable pressure to be put on the end cells and hold them all together, but I am not happy with the potential for a simple puncture going unnoticed and causing a battery to come loose inside the pack under high torque (hard cornering for example) So I am going to stick to the tried and tested “Pack em in snug” method.
I am going for 3 separate boxes to allow a couple of strong guys to lift a single box in place, if I put the whole lot in one box I would have to disassemble the whole pack to get at any of the cells, although this is unconventional it is a consequence of building my TP from individual cells rather than cell blocks that most people use (Thundersky for example)
I will get some very accurate measurements in the next couple of days and get the boxes commissioned ASAP, No time to loose now as my September deadline is approaching very rapidly :-}

Friday, 13 March 2015

Battery testing continues now that spring is finally here :-)

So I have recently gotten back out to my workshop to try and pick up on the battery testing again, there has been a big break from this due to the shitty English weather over winter and other time pressures, but with only 6 months to go before I need the RX8 (which is barely started) I need to get a move on.
I have done a few cell tests recently but have not as yet gotten back into the swing proper, just prepping the rig so that I can easily swap out cells and test 2 every 30 minutes or so has taken some time, plus the blow up of my decent Antec PSU hampered the charging situation somewhat, I have now completed charging all of the cells ready for testing (other than a few failures that need retesting, failed due to random setup failures that are not necessarily problems with the cells) 

“Honey I blew the Gearbox”

Ok so speaking of failures in my last few posts here comes another!
Yes I can now confirm that my adolescent driving style over the last year and a half has finally taken its toll on the tiny little Honda Beat gearbox :-(

After driving over the mother in laws the other night I hear the dreaded “pop” and grinding of teeth once again (barley a month after this happened before) except this time I was literally and coincidentally driving past my mechanics workshop so it was a simple matter to roll it round the corner and park it up for Brent to look at ASAP.
He got around to it a couple of days later, however this time the news was not good, I had stripped the splines from the old clutch plate that we had used to make a coupling plate from and it has also worn the splines on the gearbox as well, so a new gearbox and clutch plate are in order.

You can just see from this blurry photo that there is a distinct lack of splines in that there hole :-(

We have source a replacement gearbox and clutch plate and should hear on this Monday coming from the guy who is selling them.

For now I am back car sharing the deep fat fryer :-(

Meltdown on the Powerlab!

Here comes another failure! I was picking up on the testing rig the other day and after starting a test smelled the bad smell of burning plastic, I began checking over all the battery connections with my nose looking for the source and then the charger quit with “Banana plugs disconnected” during the test. Checked the plugs and sure enough the negative terminal on the Powerlab 8 had melted! Bugger.
Luckily I had a stack of these sort of banana sockets (albeit for old school jacks) that just so happen to be a perfect fit, and after investigating an exact replacement I discovered that they were originally of a distinctly poorer quality than the ones I had in stock, Also luckily my partner had a kids birthday party to attend with our kids so I managed to find a couple of hours to affect a repair (and a pretty nice one at that) Confident that the issue was resolved I went straight back to testing, Successfully now the melted plug has been replaced, I replaced both the –ve and +ve connectors just for ascetics reasons and made a much better mechanical connection that the poor soldered connection that were present originally.
I think the reason for the meltdown was due to the fact that my battery testing rig has a set of buss bars that are connected via banana plugs to the Powerlab 8 which means that I am not plugging and unplugging the banana jacks after each test (as you would normally if you were just testing a single cell pack) so any degradation of the banana jacks was not being noticed until it caused a problem (i.e. melted) So in order to prevent the same happening again I replaced the faulty banana jack plug with a shiny new one (stripped from a dead cell pack) and cleaned the banana jacks pin with wet and dry paper. I will just have to check the jacks more often between cell tests.
I can honestly say that if there is one thing I have learnt (the hard way) it is that the most common cause of problems with HV EV tech is bad electrical connections.

Wednesday, 25 February 2015

Second EMW charger build begins (Very slowly)

So I finally got around to clearing up my den where I have my own PC and do soldering and the like indoors and pulled out the PCB set for the next Non PFC charger build, straight away I noticed that the control board is of a different version V12 and that it has had some “Modifications” to the PCB, some of the ground plane has been drilled out in around 8 places on the board to rectify a ground plane copper flood issue that they must have had with these PCB’s, So I spent a very long time (several hours) catching up on the charger thread on the diyeletriccar forum and much to my dismay the V12 board looks like it might be a bitch to get working, we will see, I have yet to source all the components for the charger build and so I will spend a while collecting resources and parts before doing any major assembly.

Charger fans packed up!

This blog is starting to look like a long list of failures, but then I guess if you take into account that I drive and charge this baby every single working day of the week (5 days a week) and some weekends to boot then the CPU fans I used have probably not done to badly for 18 months of use charging every day throughout the miserable cold & wet winters we get here in the UK, and the last couple have been especially wet, positively monsoon like!
Went to charge night before last and when I powered up the charger the usual fan noise was not present and immediately obvious as such, I left it a while and monitored the temp but it was soon obvious that no fans would mean imminent charger death, So I powered down took the following day off and replaced the 4 small CPU fans I had used in the initial build for a larger single CPU fan and despite its now precarious securing method (zip fasteners) it is jammed quite snugly in the hole cut in the ex-engine bay and secured by a single zip fastener to stop it coming adrift, this is very definitely a temporary bodge and will need addressing properly with 2 new correctly sized fans that are double the depth and preferably a little more robust than the puny CPU fans I have been using up till now, I wonder if you can get IP rated fans I guess so, more research needed.

Also on a side note the small LCD display on the charger is starting to show signs of imminent death, it has developed a couple of line faults in both the horizontal and vertical planes, very annoying as the display is small anyway and any sort of loss of info makes it very difficult to read, also the test after the fan failed appears to have killed the temp sensor, this will also need addressing soon, now reads -68 which I seem to remember is a not present reading (obviously it has become disconnected maybe the excess heat has melted something or more likely my removal of the lid has inadvertently disconnected the temp sensor plug.

RX8 Motor Coupling

Brent called the other day to discuss the motor coupling as it turned out the Kostov K11 that came out of Steve’s MX5 had a splined coupling collar of some sort but Brent had to drill down the length of it and split it open to get the motor detached from the MX5’s gearbox, destroying the splined collar in the process, so much to my partners dismay I will have to purchase further bits to get this sorted.
After discovering that Kostov were going to charge me £235 for the coupling plate (which they incorrectly call a torque convertor for some odd reason) I found a universal coupling plate on eBay that is a perfect fit, ordered this immediately as despite the US duties I will have to pay, It is less than half the price of Kostov’s offering. In fact Kostov seem to charge well over the odds for their parts, I bought brushes for both the motors I own and bearings for the K9 and these also seemed overpriced, I will source all spares I can from elsewhere in future, in fact if I ever get more motors they will probably not be Kostov’s due mainly to the price.
Brent also needs the plastic bush coupler that goes between the K11 coupling pate and the RX8’s diff’s coupling plate.


So the parts I mentioned above arrived in good time but unfortunately the motor coupling plate looks more than a little weak to say the least it is split in several places to allow for the easy fitting I guess but this also means that there is only around a 3mm ring of metal that is going to take the full motor torque, Shit that will not do so it is back to the drawing board for this part and to top it off my mechanic gave me the RX8’s coupling plate and this will also need modifying to allow the plastic bush coupler to fit both the RX8 and Motor side.
Still I have a friend who is hopefully going to help me machine up something that will be strong enough to do the job, watch this space ;-)

Monday, 5 January 2015

RX8 Collected by mechanics “The build begins”

Sweet, So after all the fuss the Honda is fine and the mechanics have literally just collected the RX8 for the initial strip down and motor fitting, Once the mechanics have the RX8 in place and stripped I will visit Brent and discuss the build proper.
But at last at least I can actually say that the RX8 build has begun :-) Better get back to the battery testing then!

Blown Gearbox NOT! :-)

Good news, My mechanic took the Honda in this morning and by lunchtime I had a call to say that the problem was entirely their fault and I had not blown the gearbox after all.
When they serviced the motor recently with new brushes and bearings they had welded the splined collar to far along the shaft and this had caused the spline to pop out of the collar.

Funny thing is that this is exactly what I suggested the problem might be when I spoke to Brent recently he assured me that this was impossible as it was clamped in so tightly there was no room for any sort of movement.
So apart from not having the EV on the road for the last few weeks this one has not cost me a penny.